dougblack3684

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 26 total)
  • Author
    Posts
  • in reply to: Smart Card redirection Wyse 5040 AIO #50987
    dougblack3684
    Participant
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    Gemalto the vendor only support Windows/Citrix using Internet Explorer 32bit & Firefox 32bit, and it’s the Gemalto drivers/edit you need… but… it’s the passthrough from the terminal that’s the kicker. Windows IOT would passthrough as it would run the package, ThinOS 019 just re-directs using its own magic…getting Linux to do that job as an OS… I wouldn’t think so…

    in reply to: Smart Card redirection Wyse 5040 AIO #50985
    dougblack3684
    Participant
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    The issue is drivers, on a Windows build (or IOT) If you have the driver package installed, they work as the “local OS” passes through to Citrix. However as we know the idea of ThinOS is you don’t have a full blown OS, and then the extra hassle of patching, antivirus, wsus, etc etc… the whole idea between using a thin client in the first place, otherwise you’d just use a fat PC.

    dougblack3684
    Participant
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    I am mid packaging the latest Gemalto Client 6.6 IS to roll out to our Citrix farms to see if the latest release works, but I really suspect it won’t.

    Unfortunately in our enviroment different teams manage softwares, Citrix Enviroments, Vendors (Dell) getting everyone together to log a support call with Dell can be difficult….

    At the moment I am stuck on 019 as well which isn’t ideal…

    in reply to: ThinOS 8.4 and Multiple Storefronts #50474
    dougblack3684
    Participant
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    I did drop that in the advanced section of WMS, but didn’t seem to behave any differently, whats the best way of entering it?

    dougblack3684
    Participant
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    Just downloaded the hotfix  _027 and applied to a test terminal, same issue. But as soon as I roll back to _019, works perfectly again.

    in reply to: ThinOS 8.4 and Multiple Storefronts #50443
    dougblack3684
    Participant
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    So I’m trying similar but using WMS, I’ve dropped the URLS in the storefront, but I’d like to be able to choose which storefront to log in to.

    At the moment when a user puts in username, password domain, it authenticates against the first listed storefront, then fails (as expected), and successfully authenticates and logs in the second. (We have 2 Citrix enviroments we want one terminal to be able to communicate with, one is our internal, one is an external via netscaler).

    Is there any simple way to do this via WMS?

     

     

    in reply to: Smart Card redirection Wyse 5040 AIO #49897
    dougblack3684
    Participant
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    Basically, no.

    After much conversation with Gemalto and Barlcays, when using ThinOS even with the driver package installed in Citrix, you cannot use the integrated pinpad readers as they are a different class of device than a standard reader,

    “Do you support the use of a secure PIN entry smart card reader that adheres to the PCSC V2 part 10 standard”- It appears ThinOS does not.

    The solution we had to use for ThinOS clients (in our case the 3040’s) was to independently purchase card readers without the integrated pin-pad (The bank will only supply their standard ones) – in our case we ordered a ton load of these:

    https://www.dell.com/en-uk/work/shop/dell-kb813-smartcard-keyboard-uk-irish-qwerty/apd/580-18365/pc-accessories

    they work perfectly with the on-screen pinpad for the service.

    Obviously the vendor (Gemalto/Barclays) cannot provide hardware support on the products the products they don’t provide, but they did confirm a compliant smart card reader (like the Dell KB integrated one), will work with the current releases of the Gemalto package.

    in reply to: Screen Res Settings ThinOS using WMS #49834
    dougblack3684
    Participant
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    Im using the Standard version on private cloud….

    in reply to: ThinOS 8.6 Switch WMS FQDN to WMS hostname only #49833
    dougblack3684
    Participant
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    I use DHCP option tags that point to a DNS alius of the FQDN.

    Works perfectly, and was a dream to use when moving from WDM to WMS, as soon as I put the Option tags on the terminals just flipped over perfectly next re-boot with no hassle and perfect ever since 🙂

    in reply to: Export devices from WMS 1.1 #49465
    dougblack3684
    Participant
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    Yes, scripting a cleanup was my second option, but thought I’d ask in case anyone had already worked it out 🙂

     

    Thanks for the help though, this has saved me a whole heap of time!

    in reply to: Export devices from WMS 1.1 #49462
    dougblack3684
    Participant
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    Yes I did lastUser and it pulls back below:

    Yes the domain\user is there, but is there a tweak to just return that value and not the rest?

    {“_id”:{“$oid”:”5ca23250b8a5b30b0ca690c4″},”started”:{“$date”:”2019-04-01T15:46:24.000Z”},”userId”:{“$numberLong”:”0″},”userName”:”DOMAIN\USERNAME“,”device”:{“_id”:{“$oid”:”5c73e65b891655111ced509e”},”isOnline”:false,”name”:”WT8cec4b42677b”,”macAddress”:”8cec4b42677b”,”checkinInterval”:0,”cellularTechnology”:0,”timezone”:0,”wyseIdentifier”:”wyse8746011571271688465″,”ownership”:0,”hasAlerts”:false,”isJailBroken”:false,”isRealJailBroken”:0,”isLocAllow”:false,”isCompliant”:true,”compliantStatus”:1,”isInstalledAppCompliant”:true,”isConfigCompliant”:true,”isRoaming”:false,”isDataRoamingEnabled”:true,”isEmployeeOwned”:false,”isNameChanged”:false,”deviceEncryptionCompliantStatus”:1,”jailBrokenCompliantStatus”:1,”networkInterfaces”:[],”storages”:[],”wifis”:[],”mailAccounts”:[],”packageInfos”:[],”notes”:[],”nonCompliantConfigParamCatalogs”:[],”supervisedModeEnabled”:0,”androidForWorkMode”:0,”activationLockEnabled”:0,”harewareEncryptionCaps”:0,”isPasscodePresent”:true,”isPasscodeCompliant”:true,”isPasscodeCompliantWithProfiles”:true,”isCheckinCompliant”:true,”installedAppCompliantStatus”:1,”restrictedAppCompliantStatus”:1,”mandatoryAppCompliantStatus”:1,”configCompliantStatus”:1,”isVoiceRoamingEnabled”:true,”deviceProfiles”:[],”deviceProvisioningProfiles”:[],”deviceCertificates”:[],”flashSize”:0,”hasOwnerChangedSinceLastCheckIn”:false,”isCaValidationOn”:false,”isAssigned”:false,”isUsingLatestFirmware”:false,”iTunesStoreAccountIsActive”:0,”isDeviceLocatorServiceEnabled”:0,”isDoNotDisturbInEffect”:0,”personalHotspotEnabled”:0,”isCloudBackupEnabled”:0,”hasSDcard”:false,”wiFiRadio”:false,”vpnStatus”:false,”deviceSleeping”:false,”maxConcurrentDownloads”:0,”currentDownloads”:0,”supportWol”:false,”writeFilterType”:0,”writeFilterStatus”:0,”windowsAgentQueryDevice”:false,”allowFasterImageDownload”:false,”isQuarantined”:false,”adminPwd”:false,”appSandbox”:false,”onlineStatus”:1,”vendorId”:{“$numberLong”:”0″},”osBootDisk”:{“$numberLong”:”0″},”connectedServer”:0,”registrationStatus”:3,”dayNum”:0,”id”:{“$numberLong”:”2″},”updatedAt”:{“$date”:”2019-04-01T14:55:38.000Z”},”isActive”:true,”createdAt”:{“$date”:”2019-02-25T12:58:03.022Z”}},”dayNum”:0,”id”:{“$numberLong”:”0″},”updatedAt”:{“$date”:”2019-04-01T15:46:24.354Z”},”isActive”:true,”createdAt”:{“$date”:”2019-04-01T15:46:24.354Z”}}

    in reply to: Export devices from WMS 1.1 #49460
    dougblack3684
    Participant
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    That batch file massively helps, I’m on WMS 1.3, and the one field not pulling is lastLoggedInUser, is this an updated field name, if so… what’s the chances you know the new value?

    in reply to: Export devices from WMS 1.1 #49421
    dougblack3684
    Participant
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    Have you a step by step that could help people not familiar with Mongo on how to export? I myself am looking to export the fleet details with the basics – last user, IP, serial, MAC etc but struggling…..

    in reply to: Export WMS Devices #49419
    dougblack3684
    Participant
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    Has anyone a step by step on exporting from the MongoDB? Not familiar with Mongo so any help would be appreciated.

    in reply to: Discovery & Imaging issue (WDM) #49106
    dougblack3684
    Participant
    • Total Post: 34
    • Frequent Flyer
    • ★★★

    Sorted it, found it in the Rapport DB on the server table, just corrected the IP on the DB, re-started services and whoosh.

Viewing 15 posts - 1 through 15 (of 26 total)