Wyse3040 – USB Printer redirection ok but can't print

  • This topic has 2 replies, 1 voice, and was last updated 5 years ago by vinz.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #49103
    vinz
    Participant
    • Total Post: 55
    • Back Stage Pass
    • ★★★★

    Wyse3040 – USB Printer redirection ok but can’t print

    Hello,

    I want to use a USB printer (Samsung M2825ND) on my Dell Wyse 3040 (ThinOS 8.6_013 and BIOS 1.2.5).

    After reading severals subjects about the configuration, this is what I’ve done :

    In the Printer Setup :

    The Printer ID “Samsung M262x 282x Series” is the exact name of the pilot installed on my 2016 Server.

    The Test Print is OK.

    Then, in WMS, activation of USB redirection and printers mapping :

    After logging into a rdp session, I can see my printer (CL031 is the name of my Wyse3040). So the redirection seems to work :

    I can see it also in the 2016 Server. You can see that it is “Ready” (“Prêt”)

    So everythings looks good… Except when I try to print something !

    As soon as I click on “Print test page” (for example), the printer statut goes to “Hors connexion” (“Not connected”) and the document statut goes to “Redémarrage en cours” (“Rebooting”). And nothing happen, the printer keeps quiet…

    I’ve also tried all of this with another printer (HP LaserJet 1300) and HP Universal Printing driver. Same result…

    What have I missed ?

    Thank you

    #49186
    vinz
    Participant
    • Total Post: 55
    • Back Stage Pass
    • ★★★★

    A new info about this issue :

    I’ve installed Citrix HDX Monitor on my XenApp Server, and that shows me that :

    I think now that my problem comes from that inactive virtual channel…

    But how to activate it ? (I think it’s in Citrix Studio, but didn’t find how for then…)

    Thank you

    #49220
    vinz
    Participant
    • Total Post: 55
    • Back Stage Pass
    • ★★★★

    Ok so It works…

    The problem was because of a VERY stupid thing : after my long time configuring all of that, I didn’t see that the printer went asleep, and the thinclient can’t wake it up !

    I just had to push the printer power button, the printer wake up, I can print from my ICA session…

    Nevertheless,  I’ve learned an important thing thanks to this forum :  to configure a USB printer on a Wyse3040, the Printer ID must be the exact name of the pilot installed on the Server.

    I didn’t know that in the beginning…

    So thank you !

    That’s all folks ! 🙂

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.