Wyse T50 RD Broker / NLA

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #50137
    Derby1985
    Participant
    • Total Post: 22
    • Regular Joe
    • ★★

    All,

    I’m looking for advice on using a Wyse T50 to login with a RDS Collection (2019).  Since RDS 2012 R2 was released we have lost the ability to RDP to an RDS server as the load balancing mechanism now requires the user to connect to the connection broker which in turn distributes the user to least busy RDS session host.

    There is an option on the T50 (Wyse Enhanced Ubuntu) that allows us to authenticate against a broker which seems to bring through the collections.  However, when attempting to connect to one of the RDS servers it lists it now prompts stating there is an NLA issue.

    If I look at diagnostics log I can see on the temporary settings that each RDS object is pulled through with NLA=no.  This isn’t the case on the RDS collection side, NLA is enabled.  I can also see on the permanent settings that under RD Broker section that NLA=no.

    I have tried forcing NLA=yes via the WLX.ini to no avail and I have also tried disabling NLA from the RDS side (not ideal) which didn’t work.

    My question is how do I force NLA from the Wyse T50 when setup in RD Broker mode?

    #50140
    Derby1985
    Participant
    • Total Post: 22
    • Regular Joe
    • ★★

    A further update on my post- if i disable NLA both on the RDS host and on the RDS connection broker it works as intended.  However, for security purposes i would like to be able to force the Wyse Thin Client to use NLA, how can i do this? As above, i have tried putting in NLA=yes onto the wlx.ini to no avail.

    #50223
    Derby1985
    Participant
    • Total Post: 22
    • Regular Joe
    • ★★

    ConfGen, do you have any ideas? I would like the Ubuntu device to utilise NTLM sign on to allow password resets and then the ability to sign into an RDS session broker via NLA.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.