Wyse T10, choice of ThinOS version

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #97208
    • Total Post: 3
    • Newbie

    Hello everyone,

    One of my professional customers use approximatly 15 Wyse T10 in his office. Until a few weeks ago they were connected by RDS protocol to a Windows 2008 server without any problem. ThinsOS were like 7.xx or 8.0.xx version.

    Now they have a new Windows 2019 server, so I have had to upgrade all the Wyse T10 in order to connect to the new serveur. I tried the 8.6.206 firmware, but it is only 32 bits display, so it was impossible to use (display too slow).

    I came back tu 8.0.512, and now all Wyse T10 can connect to the new server.

    But there is still one problem left : users still tell me that a few times a day, they are “ejected” from the server, with no alert, neither on their own screen, nor on the event log of the server. They just have to reconnect to the RDS server and they can work again.

    Do you think the 8.0.512 version (which is “old”) could cause this deconnexion ? Should I try a newer firmware ? I’ve seen the 8.3.109 in the download section, is it a good try ? There is a 8.5.024 on the Dell website, but I don’t know if this one is newer that the 8.3.109 (due to security updates).

    Thanks for you help !

    • Total Post: 15
    • Regular Joe
    • ★★

    This may not help but I have around 70 T10 (3010) running 8.6_206 without issue. They do not respond as well as the 3040 thin clients but are very acceptable. I would recommend checking the ini because when I went to the 8.6 version there where many parameter changes in the ini file.

    Also I always check RDP from a Windows 10 machine to see if it is the server vs wyse client. Windows 10 is running the newer RDP client which has features that would be enabled in the version 8.6 firmware.


    Here is the wnos.ini I use.

    autoload=1 LoadPkg=1 VerifySignature=no
    AdminMode=yes Username=*** Password=**** ShowAdmin=yes
    WDMService=No Discover=No
    CCMEnable=No Discover=No
    Device=DellCmos WakeOnUSB=yes InternalSpeaker=no Microphone=no

    reboot=yes Time=03:00
    SysMode=VDI toolbardisablemouse=yes toolbardisablehotkey=yes DisableAddConnection=yes
    Privilege=None ShowDisplaySettings=Yes
    Language=Us ManualOverride=yes
    KeySequence=yes Ctrl+Alt+Up=no Ctrl+Alt+Down=no Ctrl+Alt+Left=no Ctrl+Alt+Right=no
    Device=Camera Disable=yes
    Device=mouse Speed=4

    Screen=1 Resolution=DDC ManualOverride=yes
    DeskColor=”0 0 0″
    Screensaver=30 LockTerminal=0 Type=0 Sleep=30

    Timeserver=time.google.com Timeformat=”12-hour format” Dateformat=mm/dd/yyyy
    TimeZone=’GMT – 06:00′ ManualOverride=yes Daylight=yes Start=030208 End=110101

    Device=Ethernet Speed=”Auto”
    MaxVNCD=1 VNCD_Zlib=yes

    Service=ThinPrint disable=yes

    SessionConfig=ALL MouseQueueTimer=1 UnmapClipboard=yes Fullscreen=yes Resolution=default MultiMonitor=yes

    SessionConfig=RDP MaxBmpCache=128 DefaultColor=2

    Host=rds.host.com \
    Description=”Remote Desktop” \
    NoReducer=yes \
    Rdp_No_Wallpaper=yes \
    Rdp_No_Animation=yes \
    Username=$TN \
    Password=1 \




    • Total Post: 3
    • Newbie

    Hello slc71

    Thank you for your answer. On my Wyse T10, when I tried the 8.6 OS, I had only the “32 bits” choice in the display settings, and it was really really slow. Do you have the possibility to choose 16 bits display on yours ?

    I remember I saw somewhere that only 32 bits display was possible with OS 8.6, like here : https://www.dell.com/support/manuals/fr-fr/wyse-3030lt-thin-client/thinos_8.6.x_rn/display-gui-update?guid=guid-5a4398cc-1fa9-414e-baf7-1b6f4f7f2042&lang=en-us

    That’s why I came back to 8.0.512.


    • Total Post: 15
    • Regular Joe
    • ★★

    We are getting true color when connecting, I have to make sure of it because we are a medical facility and our staff views imaging on our units. If the coloring is not proper it would be an issue. We also are using H.264 with our connections but this also must be enabled at a server level to work. I did this thru group policy settings on the server.

    Configure H.264/AVC hardware encoding for Remote Desktop Connections: Enabled

    Prioritize H.264/AVC 444 graphics mode for Remote Desktop Connections: Enabled

    In the config above all RDP sessions are set to true color at the session config level.

    SessionConfig=RDP MaxBmpCache=128 DefaultColor=2

    per the INI manual at a session level

    DefaultColor — Specifies the default color depth to use for
    the session 0=256, 1=High color (16-bits), 2=True Color (32-bits)

    Now there is also a RDP connection level option called colors. which has more options, but true color at a session or rdp level is the same setting. Make sure your ini does not have both specified.

    Colors={256, 32k, 64k or high, 16m, true}

    Default is high.
    Session color mode. For faster display performance, use 256
    colors for the session.
    ● 256 is 8-bits
    ● 32k is 15-bits
    ● 64k or high is 16-bits
    ● 16m is 24-bits
    ● true is 32-bits


    • Total Post: 15
    • Regular Joe
    • ★★

    Just another thought.

    I have a couple T10 devices laying around if you want to post your wnos.ini configuration I can test it on my device to see if I get poor performance.  Maybe this will tell you if it is the configuration on the Wyse client.

    I would also look in the windows 2019 event viewer log under Application and Service Logs->Microsoft->Windows->RemoteDesktopServices-RdpCoreTS.

    If there are RemoteFX issues going on it will show in there and I read many post about where RemoteFX causes disconnects and redirection issues.

    I was testing out a ncomputing device the other day and had random disconnects along with other issues and it appeared to be something with the RemoteFx settings.

    • Total Post: 3
    • Newbie

    Thanks slc71 for your last answer, I found errors under “Application and Service Logs->Microsoft->Windows->RemoteDesktopServices-RdpCoreTS.”

    It seems to be exactly the same problem as here, even if in my case I use Wyse clients to connect to a Win2019 server : https://superuser.com/questions/1598296/remote-connection-to-windows-10-sometimes-freezes .

    I’ll have to check any network problem, even if the server is up to date, and is connected to the same switch as my old server, which didn’t have any problem.

    I’ll dig this way, thanks for your guess !


Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.