Wyse S10, Storefront 2.5, XD 7.5 PW Reset Issues!

  • This topic is empty.
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #8496
    Nicholasdaa
    Member
    • Total Post: 7
    • Newbie

    Hi All,

    I’ve been stuck on this problem for several months now, but have just started investing time into it in this past month. I am working with both Wyse and Citrix support but honestly getting nowhere.

    We have Wyse S10s connecting to a PNAgent site on Storefront 2.5 with desktops being hosted by XenDesktop 7.5. I have password changes set to allow expired only and I have tried multiple options but have heard the primary option is ‘SignOn=Yes’.

    I have not been able to get past this and am hoping you can help!

    Please let me know what information you need and I’ll get it posted right away!

    Thanks,

    Nick

    #25380
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    – wnos.ini
    – firmware version

    CG

    #25383
    Nicholasdaa
    Member
    • Total Post: 7
    • Newbie

    Firmware = HF 8.0_411

    WNOS.ini =

    ;*************************************************************
    ;* *
    ;* This wnos.ini file was generated with the *
    ;* Configuration File Generator 7.1.02 *
    ;* Copyright by Thomas Moellerbernd *
    ;* *
    ;* https://technicalhelp.de *
    ;* *
    ;*************************************************************

    ;*************************************************************
    ;* General 1 *
    ;*************************************************************

    autoload=2

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    DomainList=”NOCOHA”
    MaxVNCD=1
    VncPassword=”access4me”
    VncPrompt=No Accept=5
    SignOn=yes

    ;*************************************************************
    ;* ICA *
    ;*************************************************************

    IcaBrowsing=UDP
    PnliteServer=http://store.nocoha.org/Citrix/NCHA/PNAgent/config.xml ReconnectAtLogon=0 ReconnectFromButton=0 DefaultSettings=XenDesktop Storefront=yes
    inactive=0
    ;


    ;- ICA Session 1 –
    ;- Each line but the last must end with a ” –
    ;



    ;CONNECT=ICA
    ; BrowserIP=10.83.4.11
    ; Application=”Ncha XD Desktop”
    ; Description=”Ncha XD Desktop”
    ; Logon_Mode=user-specified
    ; Domainname=NOCOHA
    ; LocalCopy=no

    AddCertificate=nocoha-rootca.cer
    AddCertificate=ncha-store2.cer

    #25386
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Either use Storefront=yes option with SF URL or don’t use it and stay with the PNAgent URL you are currently using.

    CG

    #25395
    Nicholasdaa
    Member
    • Total Post: 7
    • Newbie

    So I have tried multiple options, I have tried removing the storefront=yes option after the PNAgent URL, and adding SignOn=Yes, but that has changed nothing.

    I’ve tried SignOn=NTLM with no success, including adding the Passwordserver option and trying both ICA and RDP using both broker servers and domain controllers.

    Any other ideas? Is there any logging that gets placed anywhere that I can scan through?

    Nick

    #25396
    Nicholasdaa
    Member
    • Total Post: 7
    • Newbie

    Any ideas?

    #25397
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Have you tried to set the password change on the Citrix server to “Always allowed” ?

    CG

    #25420
    Nicholasdaa
    Member
    • Total Post: 7
    • Newbie

    Yes, while I have tried both Always or only when expired, I had found that some had said that PNAgent sites only recognize the expired or never.

    #25450
    marcj1
    Member
    • Total Post: 2
    • Newbie

    I believe you need to use SSL for password resets to be supported. My ini file looks pretty similar to yours but my pnlite server is accessed via https and my StoreFront servers are configured with SSL all the way through.

    #25451
    Nicholasdaa
    Member
    • Total Post: 7
    • Newbie

    Hmm, tried adding HTTPS instead of HTTP but that did not work either, even added certs to the WNOS file which allowed me to log in and would bring up the reset password prompt, but still password change failed =(

    #25457
    marcj1
    Member
    • Total Post: 2
    • Newbie

    And your Base URL on your StoreFront server is listed as starting with https?

    I have my StoreFront set to allow pw changes “At any time”. I also have my fully qualified domain name listed as the Trusted Domain on my StoreFront and under DomainList= on my wnos. My DHCP is set to issue this same domain to my thin clients (option 15). Lastly, i set my domain controllers as the time server for my thin clients via the wnos (Timeserver=).

    What is listed in the thin client event log when the pw change fails?

    #25458
    Nicholasdaa
    Member
    • Total Post: 7
    • Newbie

    Thank you so much for your observations and comments!!!

    It turned out the domains list on storefront and the wnos file were different. Storefront had fqdn and wnos had netbios, I changed it in the wnos and boom, works!

    Thanks for your help guys!

    Nick

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.