WMS 2.1 – new server & database migration

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #52889
    • Total Post: 9
    • Regular Joe
    • ★★

    Hello !
    We currently have Dell WMS Standard Edition installed on a Windows Server 2012 Virtual Machine.

    I want to install it on Windows Server 2019 on a new server.

    WMS was in 1.4.1 version so I first updated it to 2.1 on the 2012 VM. Then I installed and configured WMS 2.1 on Server 2019. After that, I saved and restored the DB from one server to the other using Dell documentation (Deployment Guide).*

    So on the new WMS configurations and devices are listed and it’s fine.
    But then I want to change the WMS server used by a thin client : when I manually change the server path on a Wyse (Wyse 3040 ThinOS 8.6_412) the new WMS is found, the Wyse reboots, but then I get an error “7700 sub error code 172” or “7700 sub error code 115”

    The “checkin” therefore works since my Wyse appears and is updated on the new WMS server. But the configuration is not loaded and we cannot send commands to the Wyse.
    I noticed this error has already been encountered and tried a few solutions.
    I tried a Test-NetConnection on port 1883 (MQTT) : it works, so apparently no MQTT problem.
    I tried to deactivate IPV6 on the network card : it did not improve things.

    I guess I’m not the only person who wants to update Windows on my server, so I guess it’s possible, and I guess it’s possible to recover the database as well, and not have to redo all policy configurations …

    Do you have a lead?

    Thank you in advance


    * As the save/restore commands mentioned in the documentation didn’t work properly, I had to research and adapt them. If anyone is interested please tell me so that I will post the commands that worked in my case.

    • Total Post: 2
    • Newbie

    I was running 1.4 on 2012 R2. I have a new 2019 server that I installed 1.4 on. I’m trying the same thing but I’m having 2 issues. Now that I’ve restored and upgraded to 3.0, when I go to the Setup page, I get a window that says Error: Error. The other issue I have is that it seems to be holding onto the old server name as well. I did a Forgot Password and the link it emailed me was for the OLD server and not the NEW server.

    I ended up playing with the commands as I noticed what was in the 1.4 guide was wrong. The 1.1 guide was a little better but the lines weren’t broken up. The 3.0 guide is apparently the way to go and I used the following commands:

    mongo -u stratus -p <db_password> –authenticationDatabase admin

    at the mongo prompt:

    mongorestore -u stratus -p <db_password> –authenticationDatabase admin –drop –db stratus “backup_folder_location\stratus”


    for MariaDB:

    mysql -ustratus –p<db_password> -e”drop database if exists stratus; show databases;”

    mysql -ustratus –p<db_password> -e”create database stratus DEFAULT CHARACTER SET utf8 DEFAULT COLLATE utf8_unicode_ci;show databases;”

    mysql -ustratus –p<db_password> stratus < .\wmsdump.sql


    I have yet to try to connect an existing Thin Client, for on-site reasons. 🙂

    • Total Post: 2
    • Newbie

    Seems that the solution for the Setup page is here: https://www.dell.com/community/Wyse-Management-Suite/v1-4-Issues/td-p/7309089

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.