October 4, 2023

VDI Autologin

Home Forum WTOS/ThinOS VDI Autologin

Tagged: , ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #50855
    • Total Post: 4
    • Newbie

    I have a Microsoft RD collection of virtual desktops. I am able to connect to the VDI broker and it locates the correct collection Win10_Desktops. When logging into the thin client however the connection does not auto launch. The user logs in, it authenticates, creates the RDP icon for the Win10_Desktops on the thin client desktop and then stops, making the user have to double click the RDP icon. If i open up the RDP icon properties I can set it to auto connect on sign in but then when the thin client is rebooted that config gets cleared. Is there any way to auto launch the RDP connection when configuring a VDI network connection in the .ini file? I know if i just set up an RDP connection i can configure it to auto launch but when the configuration is VDI and it creates its own RDP i dont see any option to have it auto launch that connection. Below is my .ini for reference with redacted domain info.


    VDIBroker=https://access.Domain.org AutoConnectList=Win10_Desktops
    ConnectionBroker=Microsoft RDCollections=Win10_Desktops

    • Total Post: 10695
    • Jedi Master
    • ★★★★★★★

    AutoConnectList= has to be the exact name of the “published” desktop, not the collection name.
    You can try with AutoConnectList=* to autostart all available desktops and then narrow it down with AutoConnectList=Desk*, AutoConnectList=Desktop*, etc.


    • Total Post: 4
    • Newbie

    Thomas I can not even begin to explain to you how much you and your website have helped me out over the years. Thank you so much! That worked like a charm.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.