V50LE not downloading self signed certificates

  • This topic is empty.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #6804
    chr00ted
    Member
    • Total Post: 2
    • Newbie

    Hello all, I’m hoping you may be able to help. My V50LE thin clients are unable to authenticate with citrix unless I manually add the certificates in via ICA after rebooting the thin client and hitting “g” so I’m able to access the control panel.

    Here is a copy of my wnos.ini that only works if I manually add my certs (it seems to ignore the AddCertificate entries)

    AddCertificate=startsslc2.crt
    AddCertificate=startsslca.crt
    Signon=1
    DisableGuest=yes
    AutoLoad=1
    DomainList=FMI.local
    Vncprompt=0
    defaultuser=
    signonactive=yes
    useinifiles=yes
    AdminMode=yes Admin-Username=admin Admin-Password=abc123
    Privilege=low
    Lockdown=no
    HideSysInfo=no
    HidePPP=yes HidePN=yes
    HideConnectionManager=yes
    EnableNetworkTest=yes
    EnableTrace=yes
    ShowDisplaySettings=yes
    EnableKeyboardMouseSettings=yes
    Shutdown=yes

    deskcolor=”0 51 153”

    TimeServer=time-b.nist.gov Timeformat=”12-hour format” Dateformat=mm/dd/yyyy GetBiosDT=yes
    TimeZone=’GMT – 05:00′ ManualOverride=yes TimeZoneName=”Eastern”

    pnliteserver=”https://citrix.whatever.com/Citrix/PNAgent/Config.xml”

    VncPasswd=ctms
    UsePasswd=1

    connect=ica
    Icon=default
    domainlist=FMI
    icabrowsing=https
    autoconnect=yes
    encryption= 128
    fullscreen= yes
    httpbrowsing=ssl
    colors= high
    browserip=citrix.whatever.com
    keepalive=127
    mapdisks=127
    unmapusb=yes
    unmapserials=yes
    unmapprinters=yes
    unisession=yes
    sessionreliablility=yes

    #20927
    chr00ted
    Member
    • Total Post: 2
    • Newbie

    The errors I see in thin clients system information/System Log are:
    cp: /etc/addons.d/IMPORT_CERTS/curl-ca-bundle.crt: No such file or directory
    cat: /etc/certificates/*: No such file or directory

    #20957
    ConfGen
    Keymaster
    • Total Post: 10692
    • Jedi Master
    • ★★★★★★★

    Where have you saved your certs on the fileserver?

    CG

    #21085
    spez
    Member
    • Total Post: 2
    • Newbie

    Hi

    Were you able to sort this issue? We’re getting the exact same behavior on S50 thin clients running 6.6.2.12.

    It seems to ignore the AddCertificate setting and we’re getting the same “No such file or directory” errors you pasted.

    Manual import in control panel works.

    We store the certificates in wlx/cacerts

    #21089
    ConfGen
    Keymaster
    • Total Post: 10692
    • Jedi Master
    • ★★★★★★★

    The AddCertificate parameter is not supported by Linux v6. You have to import the cert using the local Certificate Manager.

    CG

    #21092
    spez
    Member
    • Total Post: 2
    • Newbie

    Oh dear…..

    Is it possible to import it somehow using Wyse Device Manager?

    It can probably be automated by scripting?

    #21095
    ConfGen
    Keymaster
    • Total Post: 10692
    • Jedi Master
    • ★★★★★★★

    Pretty sure this is possible but I do not have a script available.

    CG

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.