USB Redirection

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #8253
    krex
    Member
    • Total Post: 1
    • Newbie

    Hi!

    I have a jabra headset 9450 its a HID device and it has the following USB class
    Composite class VID=0b0e pid=1022 Usbclass=00 usbsubclass=00 Usbprotocol = 00

    Input Device HID VID=0b0e pid=1022 Usbclass=03 usbsubclass=00 Usbprotocol = 00

    USB Audio VID=0b0e pid=1022 Usbclass=01 usbsubclass=01 Usbprotocol=00

    I am trying to force the Audio to be local and then redirect the other to be redirectet. the goal is to use HDX audio for the headset but still be able to use the HID commands.

    but i cant get this working for Citrix policy i have set and deny to USB Audio and allow to HID, and Composite device in the ini file i have forcelocal to the Audio class and Forceredirect to Composite and HID

    but it is not working if i set all 3 Things to force local i get is as HDX audio, but if i put HID or composite to Forceredirect it passes everything into the session. any ideas

    the goal is to use HDX audio but keep the function such as picking up the phone on the headset

    #49484
    Axell
    Participant
    • Total Post: 9
    • Regular Joe
    • ★★

    Have the same issue, it is always redirects nothing or full device.

    #49518
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Have you tried with InterfaceRedirect parameter, like

    Device=vusb ForceRedirect=0x1,0x1,0x1,0x1,0x1 InterfaceRedirect=yes

    CG

    #49532
    Axell
    Participant
    • Total Post: 9
    • Regular Joe
    • ★★

    Hello ConfGen

    Yes, we try to use

    Device=vusb ForceRedirect=0x1,0x1,0x1,0x1,0x1 InterfaceRedirect=yes

    Device=vusb LocalRedirect=0x1,0x1,0x1,0x1,0x1 InterfaceRedirect=yes

    and Force… IntRedir=no

    Local…IntRedir=no

    we try all of combinations, and have one result: it passes everything into the session

    But want to redirect only buttons.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.