USB Audio/MIC Redirection VMware View

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #48179
    smith_ll
    Participant
    • Total Post: 101
    • Legend in Own LunchBox
    • ★★★★★

    Hi CG,

    I’m having an issue getting a USB device (Jabra Evolve 30) redirection through to my VMware View session. The USB device pulls through and is visible within the session, but monitoring my event log when connecting I can see the below;

    12:16:15.051 AUDIO: Change record device to Jabra EVOLVE 30
    12:16:15.051 AUDIO: Change playback device to Jabra EVOLVE 30

    Showing the Audio device is now Jabra Evolve 30…

    12:17:09.523 AUDIO: Change playback device to SST Audio
    12:17:09.523 AUDIO: Change record device to SST Audio

    Audio playback devices revert to SST Audio.

    Is there a setting somewhere I am missing to prevent this behavior?

    Regards,

    LS

    #48186
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Looks like you are redirecting the USB headset via USB redirection. When it is redirected, ThinOS does not see it any longer and therefore switches to the inbuild audio instead.
    Do you have issues using the Jabra in the session?

    CG

    #48189
    smith_ll
    Participant
    • Total Post: 101
    • Legend in Own LunchBox
    • ★★★★★

    Hi CG,

    Yeah the device itself is listed in devices and when I press one of the call receiver buttons on it, it will open Cisco Jabber as it should.

    Wyse 3040, ThinOS 8.5.020, BIOS 1.2.4

    Regards,

    LS

    #48190
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    OK, great. Where is the problem then?

    CG

    #48191
    smith_ll
    Participant
    • Total Post: 101
    • Legend in Own LunchBox
    • ★★★★★

    Hi CG,

    I have no audio through to the remote session.

    headsets works on other Windows devices, and headsets connected to audio jack work fine.

    When it says SST Audio is it the right device it’s pulling through as audio,? I can see the USB side of it is passing through but feels like it’s defaulting to another audio device maybe?

    #48214
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Post your wnos.ini

    CG

    #48227
    smith_ll
    Participant
    • Total Post: 101
    • Legend in Own LunchBox
    • ★★★★★

    Hi CG,

    DefaultUser=”” DefaultDomain=domain.com
    TimeZone=”GMT” ManualOverride=Yes TimeZoneName=”GMT” daylight=No
    Signon=Yes SaveLastDomainUser=no LastUserName=No
    TimeServer=10.10.10.100 DateFormat=dd/mm/yyyy TimeFormat=”24-hour format”
    DisableDomain=Yes
    EnableGKey=No
    PlatformConfig=All EncryptFS=Yes
    WDMService=No QuickMode=Yes
    ThinPrintEnable=Yes
    MaxVNCD=No
    FastDisconnect=No
    AdminMode=Yes Admin-Username=MEAFMNABMK Admin-Password=NGAHMDBEMFAFMEFAMNFBMD ShowAdmin=Yes
    Privilege=low EnableTrace=No LockDown=No ShowDisplaySettings=No EnableKeyboardMouseSettings=Yes DisableChangeDateTime=Yes
    SignOn=Yes ExpireTime=0 RequireSmartCard=No SCRemovalBehavior=0 DisableGuest=Yes
    MaxVNCD=1 VNCD_8bits=No VNCD_Zlib=No
    VNCPrompt=no reject=10 ViewOnly=No ActiveVisible=No
    SecurityPolicy=low SecuredNetworkProtocol=No TLSMinVersion=1 TLSMaxVersion=3 DNSFileServerDiscover=Yes
    DesktopColorDepth=32
    Screen=1 Resolution=DDC Rotate=None refresh=60
    Dualhead=Yes Mainscreen=1 Align=Bottom Swap=No Taskbar=mainScreen Orientation=hort MonitorAutoDetect=Yes
    ScreenSaver=0 LockTerminal=0 Type=0 PictureTimer=6 PictureOrder=Default PictureCheck=Default PictureLayout=stretch
    Screen=2 Resolution=ddc refresh=60 rotate=none
    AutoSignoff=yes Shutdown=no Reboot=yes
    ShutdownCounter=10
    desktop=”imagenew.jpg” layout=Stretch
    SysMode=VDI Toolbardisablemouse=no Toolbardelay=2 toolbarautoquit=Yes Toolbar_no_conmgr=No Toolbardisablehotkey=No Toolbarenableonesession=No toolbarstay=1 toolbarclick=No ToolBarAutoQuit=No EnableLogonMainMenu=No
    AutoLoad=2 VerifySignature=yes
    ConnectionBroker=VMware \
    host=https://horizon.view.co.uk SecurityMode=low ConnectionType=Blast AutoConnectList=””

    SessionConfig=all \
    unmapprinters=yes unmapserials=no smartcards=no disablesound=no mapdisks=no disksreadonly=no unmapusb=no VUSB_DISKS=yes VUSB_AUDIO=yes VUSB_PRINTER=no VUSB_VIDEO=no MultiMonitor=yes FullScreen=yes

    Reconnect=1

    NoReducer=no

    LowBand=no

    FastDisconnect=no

    SessionConfig=PCoIP \
    USBRedirection=PCoIP ShowDisconnectMessage=no ShowReconnectMessageTime=50 ResumeTimeout=1200

    KeyboardLayout=Uk Charset=ISO-8859-1

    Device=keyboard \
    repeatdelay=2 repeatrate=1

    KeySequence=yes Ctrl+Alt+Del=no Ctrl+Alt+Up=no Ctrl+Alt+Down=no Ctrl+Alt+Left=no Ctrl+Alt+Right=no Win+L=no Alt+Tab=no

    Device=vusb \
    ForceRedirect=0x0b0e,0x1017,0x01,0x01,0x00 ForceLocal=”” Type=”” InterfaceRedirect=yes

    Device=vusb \
    ForceRedirect=0x0b0e,0x0303,0x01,0x01,0x00 ForceLocal=”Jabra EVOLVE 30″ Type=”” InterfaceRedirect=yes

    Device=vusb \
    ForceRedirect=0x0b0e,0x0304,0x03,0x00,0x00 ForceLocal=”Jabra EVOLVE 30″ Type=”” InterfaceRedirect=yes

    AutoPower=no

    Locale=us load=no

    MirrorFileServer=yes

    TerminalName=$SN reboot=no

    Inactive=0 NoSessionTimer=0

    reboot=yes Idle=0 Wday=Monday,Tuesday,Wednesday,Thursday,Friday,Sunday time=03:00-04:00

     

    Just to clarify, the device shows within Devics control panel but does not seem to play or record any audio within the session. Prior and after the logon I can view the device within Peripherals and it records and plays back audio fine.

    #48233
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Alter VUSB_AUDIO=yes to VUSB_AUDIO=no

    CG

    #48237
    smith_ll
    Participant
    • Total Post: 101
    • Legend in Own LunchBox
    • ★★★★★

    Hi CG,

    Thanks for the assistance as always. I’m configuring via WMS, I don’t suppose you can point me in the direction of where that exact setting is?

     

    LS

    #48239
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Remote Connections – Global Session Settings – Exclude Audio devices

    CG

    #48240
    smith_ll
    Participant
    • Total Post: 101
    • Legend in Own LunchBox
    • ★★★★★

    VUSB_AUDIO=no has fixed the issue. Microphone and headset now pull through correctly.

    Microphone quality is still poor when having a conversation though. I’ve had an ongoing call with Dell support for a few months for this. Multiple headsets tried, all produce the same.

    Speaker quality is fine, microphone quality poor.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.