Upgrade to WMS 3.6 from 3.5.2

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #107103
    Jim Lathan
    Keymaster
    • Total Post: 314
    • Jacked into The Matrix
    • ★★★★★★

    Hello all,

    I would like to ask  you if anybody tries to make the upgrade from wms 3.5.2 to 3.6

    I receive an error and when I look in the log I see this :

    Upgrade::5691::MariaDB status: The system cannot open the file.

    Upgrade::5696:: /c mysql_upgrade -ustratus -p******* -P3306
    Upgrade::5700::Failed to upgrade mysql Incorrect function.

    Point: MongoDB server version is currently: 4.2.16  dell say you need 4.2.17  ?

    But I can’t upgrade MongoDB? it is part of the installer of wms , correctly?

    Thank you for your help 😀

    #107104
    Chris S
    Participant
    • Total Post: 62
    • Back Stage Pass
    • ★★★★

    Hi,

    I opened a ticket with Dell regarding this and got this back:

    1.       Kindly refer link: https://www.dell.com/support/manuals/en-us/wyse-wms/wyse-wms_3.0_hag/Upgrading-from-Wyse-Management-Suite-version-141412×21-to-Wyse-Management-Suite-version-3x?guid=guid-f82eda49-4a74-4f95-b83b-b1ca5cb0fbc5&lang=en-us

    I  told them that my service properties window don’t even look the same and I’m waiting for a response but it does mention upgrading the MongoDB so maybe that will help you. I’m still unsure what version the mongo database is and even asked them so but considering its a brand new install of 3.5.2 and not an upgrade why would it need to be upgraded.

    #107189
    lolix
    Participant
    • Total Post: 271
    • Jacked into The Matrix
    • ★★★★★★

    3.5.2 to 3.6-241 went well

    while the previous upgrade from 3.3.1 to 3.5.2 failed. (MariaDB pb..)

    (Why this product needs two databases anyway ? Seems overkill)

    #107197
    jamauai
    Participant
    • Total Post: 24
    • Regular Joe
    • ★★

    Have you received a response yet? Or is this still an issue for you?

    #107314
    trtous
    Participant
    • Total Post: 9
    • Regular Joe
    • ★★

    Hi, have anyone find the solution? I have the same problem as MartinK..

    #107318
    Chris S
    Participant
    • Total Post: 62
    • Back Stage Pass
    • ★★★★

    I highly suggest you try this on a test server first and do snapshots before proceeding. Everything not in bold is straight from them. 

    Also after the upgrade I had tested importing AD groups and then created and assigned a Role template. After that I imported the users that were in the groups. This broke the server and I had to revert.

    I tested this on 2 test servers but haven’t upgraded my production server yet because of the problem with the AD groups and wanted to see what Dell said since I just opened a ticket with them Friday.

    First Dell had me try this:

     

    Please try the manual steps:
    Install a new copy WMS (new server). In the old install of WMS, rename the MongoDB folder to MongoDB,old and copy the MongoDB folder from the new install to the old install folder. if there is a MariaDB folder in the old WMS folder, then go into that folder and rename bin to bin.old and copy the bin folder from the new install to the old.

    Then try to install 3.6.2.

    These didn’t work for me.

     

    Next, they had me do this:

    Step 1 : Backup
    DB Backup before starting the upgrade:

    1.   Command to take Backup of DB :

    > TARGETDIR\MariaDB\bin\mysqldump.exe –routines -u<MysqlDBuser> -p<DBpassword> -P<DBPort> -hlocalhost <MysqlDBuser>  > “TARGETDIR\MariaDB\bin\stratus.sql”

    This is how it looks when I type it in.

    C:\Program Files\DELL\WMS\MariaDB\bin\mysqldump.exe –routines -ustratus -p<yourdatabasepassword> -P3306 -hlocalhost stratus > “C:\Program Files\DELL\WMS\MariaDB\bin\stratus.sql”

    Just take out <yourdatabasepassword> and put yours in.

    1.   Stop ALL WMS Services.

    1.       Tomcat

    2.       Memcached

    3.       Mqtt

    4.       MongoDB

    5.       MariaDB

    I had a problem deleting the MariaDB even though it said it was shutdown. I had to reboot the server and shutdown the services again. Then I was able to delete it.

    1.   Archive the old binaries:

    1.       Copy MariaDB from “TARGETDIR\MariaDB” to “TARGETDIR\Archive” folder and Delete  “TARGETDIR\MariaDB” folder

    2.       Copy SQL DB folder from “TARGETDIR\Database” to “TARGETDIR\Archive\Database” folder.

    Step 2: Upgrade MariaDB
    MySQL Upgrade steps:

    1.   MariaDB Binary location: https://archive.mariadb.org/mariadb-10.6.5/winx64-packages/mariadb-10.6.5-winx64.zip [archive.mariadb.org]

    2.   Copy New MariaDB-10.6.5 Binaries to TARGETDIR\MariaDB folder.

    3.   Rename the SQL log file – TARGETDIR\Database\SQL\ib_logfile0 to “ib_logfile0.old”

    4.   Rename the SQL log file – TARGETDIR\Database\SQL\ib_logfile1 to “ib_logfile1.old”

    5.   Start MySQL service.

    6.   Run below command for MySQL Table migration.

    >TARGETDIR\MariaDB\bin\ mysql_upgrade -u<MysqlDBuser>  -p<DBPassword> -P<DBPort> –debug-check –debug-info

    This is how it looks when I type it in.

    c:\program files\dell\wms\mariadb\bin\mysql_upgrade -ustratus -p<yourdatabasepassword> -P3306 –debug-check –debug-info

    Just take out <yourdatabasepassword> and put yours in.

     

    1.   Check for “TARGETDIR\Database\SQL\”mysql_upgrade_info” file creation after running the above command successfully.

    Step 3: Start All Services
    1.   Start ALL WMS Services.

    1.       MariaDB

    2.       MongoDB

    3.       memcahced

    4.       mqtt

    5.       Tomcat

    Launch application and check for sanity.

    Step 4: Upgrade to WMS 3.6
    I didn’t have to use these steps, so I don’t know if they work.

    Optional Step
    Rollback Steps for MySQL upgrade:

    1.   Stop the MySQL service.

    2.   Delete “TARGETDIR\MariaDB” folder

    3.   Delete “TARGETDIR\Database\SQL” folder

    4.   Copy the Old MariaDB folder from “TARGETDIR\Archive” to “TARGETDIR”

    5.   Copy the Old SQL folder from “TARGETDIR\Archive\Database\SQL” to “TARGETDIR\Database”

    6.   Start the MySQL service.

    7.   Run below command to Restore Mysql DB:

    Step1: Drop DB cmd:  >TARGETDIR\MariDB\bin\mysql.exe –verbose -u<MysqlDBuser>  -p<DBPassword>  -P<DBport>  -hlocalhost -e “DROP DATABASE <MysqlDBuser> ”

    Step2: CreateDB cmd:  >TARGETDIR\MariDB\bin\mysql.exe –verbose -u<MysqlDBuser>  -p<DBpassword>  -P<DBport>  -hlocalhost -e “CREATE DATABASE <MysqlDBuser> DEFAULT CHARACTER SET utf8 DEFAULT COLLATE utf8_unicode_ci”

    Step3:  Restore cmd:  >TARGETDIR\MariDB\bin\mysql.exe –verbose -u<MysqlDBuser>  -p<DBPassword> -P<DBport>  -hlocalhost <MysqlDBuser> < ” TARGETDIR \MariaDB\bin\stratus.sql”

     

    #107323
    migeauxy
    Participant
    • Total Post: 21
    • Regular Joe
    • ★★

    Same issue for me – The upgrade fails after the archiving step

     

    2022-3-8 T07:10:54::Upgrade::5691::MariaDB status: The system cannot open the file.

    2022-3-8 T07:10:54::Upgrade::5696:: /c mysql_upgrade -ustratus -p******* -P3306
    2022-3-8 T07:10:55::Upgrade::5700::Failed to upgrade mysql Incorrect function.

     

    please advice

    #107325
    Chris S
    Participant
    • Total Post: 62
    • Back Stage Pass
    • ★★★★

    That’s what was happening to me I had to upgrade the MariaDB which are the instructions above. Unless you tried that then I would call Dell. They needed logs to figure out how to fix my problem.

    #107328
    migeauxy
    Participant
    • Total Post: 21
    • Regular Joe
    • ★★

    Hi Chris S

     

    I did what you did and i’m running now WMS 3.6

    to be able to delete all the MariaDB Fodler, indeed you have to reboot the server, but having set the services to disabled, otherwises it didn’t work for me

     

    and after the MariaDB Update, the WMS update worked as expected.

     

    Thanks

    #107330
    Chris S
    Participant
    • Total Post: 62
    • Back Stage Pass
    • ★★★★

    Thats great, I’m glad it helped someone.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.