Upgrade 3040 From 2.0 To 2.1 FW

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #49273
    elproducto
    Participant
    • Total Post: 94
    • Back Stage Pass
    • ★★★★

    WYSE recommend you install four addons prior to uprading to 2.1 firmware from 2.0 firmware.  This is due to imaging process not recognizing the 3040 correctly.  Without these addons some unit give an error along the lines of there is an issue with the security key.  Someone in engineering messed up, and is passing on the bulk of corrective action  to us the WYSE admin.

    The four addons have to be installed one at a time via WMS application policies.  This approach is very time consuming and is not well suited for upgrading many 3040 clients brand new in box that have 2.0 firmware from factory.  Instead I applied these addons by adding the following INI snytax in my configuration groups advanced configuration setting instead.   You will need to spin up a webserver, and create an addons folder with the following addons in the folder. In addition you will also need to setup your configuration profile with a File Server / Path & Root Path in Central Configuration that point to folder containing addons folder created on webserver.

    One more thing I did was to use MerlinUpdate.URL INI sytax to upgrade firmware, but once the four addons are installed you can use WMS to upgrade the firmware.  I used this approach because I noticed client would apply firmware, check into WMS, and begin imaging again.  The image looping issue seems to have gone away, but I am still testing

    InstallAddons=wda3040_3.0.10-01_amd64.deb;platform-util_2.3.1-04_amd64.deb;wda_3.3.1-04_amd64.deb;3040-tl2.1-pre-upgrade-fix_1.0.0-14_amd64.deb

    #49344
    bcp
    Participant
    • Total Post: 11
    • Regular Joe
    • ★★

    Is the 2.1 FW out? I don’t see it on the Dell site.

    #49346
    ConfGen
    Keymaster
    • Total Post: 10692
    • Jedi Master
    • ★★★★★★★

    2.1? We are already at 2.6, which is posted on the Dell support site.

    CG

    #49347
    bcp
    Participant
    • Total Post: 11
    • Regular Joe
    • ★★

    Here? https://www.dell.com/support/home/ca/en/cabsdt1/product-support/product/wyse-3040-thin-client/drivers

    I only see some add-ons and the pre-upgrade fix for ThinLinux v2.1.

    #49348
    ConfGen
    Keymaster
    • Total Post: 10692
    • Jedi Master
    • ★★★★★★★

    Sorry. Thought you were talking about ThinOS lite. Didn’t even realized it is a 3040, for which Dell never released ThinOS lite.
    Nevertheless, you can find ThinLinux 2.1 on exact this site.
    Just switch the OS type on the top drotpdown box to ThinLinux.

    CG

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.