Thinos 9.x Keyboard layout issues

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #107938
    schurmb
    Participant
    • Total Post: 43
    • Frequent Flyer
    • ★★★

    I have a strange issue with the Japanese IME becoming active on thinos 9.x.

    Which screws up the keyboard layout. We use server 2016 as VDA OS with Citrix 7.15.

    No japanese language is added in the VDA, nor on the thin client.

    I have tried different keyboard layout modes in the Wyse console, but non of them solve the issue. IgnoreRemotekeyboardLayout reg key has been set to 1, but also didn solve the issue.

    I have previously set the following reg keys to enable unicode keyboard mapping:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\CtxKlMap\EnableKlMap value= DWORD 1
    HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\CtxKlMap\DisableWindowHookvalue=DWORD 1

    This solves the issue, but I had to revert them because they caused issues with macro’s in Excel.

    https://support.citrix.com/article/CTX310699/ms-office-excel-macros-might-run-slow-inside-an-ica-session

     

    Does anyone have another idea how to solve this without these reg keys?

     

    Kr

    #107939
    schurmb
    Participant
    • Total Post: 43
    • Frequent Flyer
    • ★★★
    #107942
    schurmb
    Participant
    • Total Post: 43
    • Frequent Flyer
    • ★★★

    Issue was resolved by downgrading thinos and Citrix workspace app.

    Wyse 3040 was upgraded from 9.1.3129 to thinos 2208. When downgrading to 9.1.5067 with workspace app 21.6, the issue was gone.

    Strangely after updating from 9.1.5067 to 9.1.6108 and after wards to 2208 the issue didn’t occur again.

    Will see if I can replicate it again.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.