ThinOS 8.6 / Microsoft RDS setting by user ?

Viewing 1 post (of 1 total)
  • Author
  • #106584
    Jim Lathan
    • Total Post: 314
    • Jacked into The Matrix
    • ★★★★★★


    I have an RDS farm with multiple collections.

    I use Wyse 3040 with ThinOS 8.6_807 to connect on my RDS farm, and it works.

    I specify the global connection settings in the wnos.ini file like this :

    SignOn=Yes EnableOK=yes DisableGuest=yes LastUserName=no EnableMessage=no

    To restrict a user to access to a single collection, I specify the settings below, in the user’s .ini file :

    SessionConfig=RDP mapdisks=yes VUSB_DISKS=yes
    ConnectionBroker=Microsoft ConnectionType=RDP Host=https://apps.domain.local RDCollections=COLLECTION01

    At the very first boot the Wyse, only a user with an .ini file in /wyse/wnos/ini/ can logon on the Wyse. And he sees only “COLLECTION01”. Normal behavior here.

    Here’s my problem now.

    After the first connection of the previous user, the global “Broker Type” and “Broker Server” settings are configured with the values of the first user’s .ini file.

    Then, if a user without .ini file, logon on the Wyse, he sees all RDS collections which he has access …

    But I want to restrict the access only to the users who have an .ini file.

    How to do that ? With the settings “SignOn=yes” and “DisableGuest=yes” I believed it does the job.

    Thank you for you help.



Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.