S30 and USB memorysticks

  • This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #977
    • Total Post: 6
    • Newbie

    Okay, S30 , latest firmware (581)

    There is a USB mass storage Control Panel widget. It is configured as full access. My ICA user are able to mount local disk. It does so everytimes I connect with a PC.

    The S30 do not give any notice when I plug in an usb stick. I’ve tried this with an old 3125 , and that unit popped up an error message.

    Anything I’m missing here?

    • Total Post: 1649
    • Jacked into The Matrix
    • ★★★★★★


    You will not see any dialog when you plug in the USB key on the terminal however it “should” be mounted in the Citrix session. You can not see the USB key in the session?


    • Total Post: 96
    • Back Stage Pass
    • ★★★★

    I’ve done a lot with USB devices, specifically mass storage devices, and I have to say it’s very unreliable.

    With that said, I found that certain versions of the MSSTorage Driver/addon worked best. Specifically, the changes after b19 broke ALL of my devices (including simple USB memory sticks). This remained broken until b31. In between those versions, they played with some new logic that caused the machines to pop up messages, reboot, and do other funky things. Becuase of that, I would recommend dropping way back to b19, or getting build 31 or newer.

    From within Citrix, you shouldn’t see any type of popup when you insert a USB drive unless the system doesn’t know how to handle it. If this is the case, you’ll get a message asking you to specify the driver, but at that point, I’m pretty sure the process is broken because if the driver was on the system, it would have automatically found it and started working. I saw this message in build 29 for many common USB flash drives (I test about 6 different models).

    So once you get yourself a working MSSTorage driver that likes the devices you’re plugging in, and you’re happy with the user interaction required when the device is plugged in, you need to map a drive to it. You can do this by mapping to \clienta$ from within your citrix session. You don’t necessarily have to map a drive — you could browse to that location if you have the access to do that from within your citrix session.

    It’s been a while since I’ve played around with this, but I seem to remember that the a$ share is always there. When it recognizes media, it mounts it to the share and the files will “appear”.

    In summary, if you’re having problems, get the latest MSStorage driver and give it a shot. If that doesn’t fix it, give build 31 a shot, and then build 19 if that one doesn’t do it for you.

    If you don’t mind me asking, what type of devices are you using? Just flash drives? What version of the driver are you using? You can find that in the control panel/addons applet.

    And most importantly, what’s that error message that pops up? Is it the one aslking you for a driver that I mentioned above?

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.