S10’s suddenly ignoring the wnos file? Help!?

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #5525
    Fanflame
    Member
    • Total Post: 22
    • Regular Joe
    • ★★

    Hi Everyone,

    I have only just found this forum so I am pleased that I may get some help on an issue that is going on…

    I have approx 27 S10 WTOS in our Company:

    . 10 are in HQ and connect via TS to var:ous servers.
    . 5 are in another Sales office that also connect via TS to various Servers.
    . 12 are in Regional Offices that connect via Citrix.

    Last Wednesday Morning all the Regional office WTOS reset themselves to Default and lost all their settings for no apparent reason. AS they were locked down to the settings in the wnos file I thought it would be difficult to manually resett them but no! I talked everyone through it and got everyone connected but the WTOS all ignored the wnos file and reset again when everyone logged off that night!

    I cannot fathom why they are doing this and ignoring the wnos file. I haven’t moved it and it is on the dns published ftproot folder (ftpWyseWnos).

    . Have anyone else ever had this happen to them?
    . Has the wnos path changed?
    . the wnos.ini file has always been in the root of the wnos folder not in the wnos/ini folder?

    Any help would be apprecited.

    Fanflame
    😉

    #17170
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Hi,

    can you check on one of the failing units which Fileserver entry it has?
    Do you push the Fileserver entry via DHCP?
    Have you recently installed WDM in your network?
    Which firmware are you running?

    CG

    #17185
    Fanflame
    Member
    • Total Post: 22
    • Regular Joe
    • ★★

    Hi There CG,

    Thanks for your reply; Each WTOS picks up its IP address from the local Cisco PIX and this in turn has the DHCP options of 161 and 162 pointing to the FTP server.

    On the ftp server I have a Shared folder ftproot and in there is the Wyse/wnos folder.

    I have just checked on one of the WTOS and it is looking to ftp:/wnos/RCA_wnos ( that file is in there and it is version 5.1.038 which may be older now I am not sure. I replaced the file a year ago and when I tried to download an update about 6 weeks ago I got a error message saying that I had to now contact the WYSE team and when I dio dthat they told me I didn’t have a SUpport contract (which I didn’t even know existed and I have never had one)

    I have approx 30 WTOS – all S10 of which some are 5 years old and some are recent; the newer S10’s will not update their software as I have autoload set to option 2 (update only).

    I haven’t rolled out the WDM on the system as I haven’t had time to get to know the product but did downoad it onto my Desktop.

    Any help is greatly appreciated. 🙄

    Brian
    aka Fanflame

    #17186
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    On the ftp server I have a Shared folder ftproot and in there is the Wyse/wnos folder.

    I have just checked on one of the WTOS and it is looking to ftp:/wnos/RCA_wnos

    If you have put the wnos.ini and the RCA_wnos firmware file to ftproot/wyse/wnos and on the client you just see ftpserver/wnos then you are defintely in the wrong folder.
    According to the local config your wnos.ini should be in ftproot/wnos/wnos/wnos.ini

    CG

    #17191
    Fanflame
    Member
    • Total Post: 22
    • Regular Joe
    • ★★

    Hi Yes when I wrote it I thought the same however it was this way for several years and it only changed last week when overnight all the WTOS reset to a default setting that I couldn’t find anywhere and then I had to manually change them as they couldn’t see the wnos.ini file.

    As a matter of interrest: the DHCP option 162 = /$

    That is how it was always and went through this with our new Networks Manager the other day to mke sure that it was still set that way on the new PIX, which it is??

    Is this correct?

    Many thanks

    Brian
    aka Fanflame

    #17192
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Setting OT162 to /$ means that at client site the Fileserver path will be set to just “/”, so the complete Filesserver entry would be OT161+OT162=yourfileserver/
    If your login name is still anonymous then the wnos.ini file should be in
    ftproot/wnos
    The folder “wyse” is just used when the OT162 is either not set at all or the value does not end with a “$”.
    Read my “First Steps” doc in the Products section to get more clarification.

    CG

    #17198
    Fanflame
    Member
    • Total Post: 22
    • Regular Joe
    • ★★

    Hi CG,

    Thanks for your help; I am still having issues with peoles WTOS. I do not look after the new CISCO PIX and have no access to them – however, I have had the engineer change DHCP option 162 to read ascii /

    this has removed the $ which has been there for the last 5 years.

    However, even though I have ammended the path on the ftp server so the wnos.ini is found here – ftp/wnos/wnos.ini the WTOS still will not read or update them selves.

    THis is really getting me down.

    In the system information the Event Log stop at SNTP Error 25?? do you know what this is?

    I am logging into just one remte WTOS to check all this. Others have got theiors online and are working manually.

    Can you point me to the Getting Started doc you mention please.

    Brian

    #17201
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Click on “Products” in the top part of this website. Then select WTOS and look for the “First Steps” doc.
    If you like I can try to log in myself to your environment.

    CG

    #17213
    Fanflame
    Member
    • Total Post: 22
    • Regular Joe
    • ★★

    Hi CG,

    Thanks for the reply; I have a real headache this morning. One of our servers has a peice of MAware on it which is taking up a lot of my time!

    Plus I still have the WTOS which are now trying to connect to ica but are now timing out on trying to connect to the Citrix Desktop! Headache! ( yesterday I removed the $ from the local firewalls/PIX so that they read 161=ascii / and moved the Ftp/Wyse/wnos folder on the ftp server to ftp/wnos)

    If we were to shadow each other how would you suggst we did this? However i am the only UK Domain Admin and I do not look after the network…

    Brian
    aka Fanflame

    #17214
    Fanflame
    Member
    • Total Post: 22
    • Regular Joe
    • ★★

    Hi CG,

    I have downloaded the Getting started document and understand that; what I cannot understand is that everything was working for 4 years without a hitch and then it all changed last week and the WTOS canot see, or read the File Server:

    Again, for me DHCP option 161 is set to the IP address of the FTP server
    DHCP option 162 was set to /$ (for 4 years) now it is set to /

    I logged into one of the WTOS in Shannon through the VPN and can see that the WTOS accepts the passwotd I put into VNC and that the settings are greyed out so it is locked down, however it is not reading/updating or applying the wnos.ini file – I am getting really desperate now as I have people screaming at me!

    I have just logged into WTOS in other Regional Offices adn they are all now Updating and connecting to the Sign In screen for our Citrix Desktop. I can see that it is only the Shannon office whch is now not connecting and I am tryiong to find out why – the NEw Netwoek Engineer has recently replaced their PIX and I have no access to this. However, he tells me that under DHCP OPtions he has:
    150= (our DC IP)
    161= (our ftp IP)
    162=ascii /

    he tells me that as it is a Cicso device it must have the words ascii there??

    I also seem to get in the logs ast all Regional Offices an “SNTP: -1 errno: 4
    Do you know what this is as I assume it is the time server as it tries again within a few seconds and get the same error?

    Brian
    aka Fanflame

    #17215
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Shadowing would be a start.
    Do you know “Teamviewer” from teamviewer.com.
    Send me a PM if you have it running.
    I would need access to your FTP server and one of the clients (even if only via VNC).

    CG

    #17218
    Fanflame
    Member
    • Total Post: 22
    • Regular Joe
    • ★★

    Hi CG,

    Our company was purchased by a US company and their IT team only has access the the ftp server! In fact we have a situation where the Regional offices look through a subnet and therefor has its own FTP server however, this is all greyed out to me and I cannot change anything without asking them.

    Add to that I am no able to log onto any PIX and it compounds the issue.

    However we are getting there slowly.

    regarding DHCP Option 162 what should this be set too if I have the wnos in the following location ftp/wnos

    now t is set to 161=ascii /

    Brian

    #17220
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Just set it to $

    CG

    #17222
    Fanflame
    Member
    • Total Post: 22
    • Regular Joe
    • ★★

    OK Thanks I will try this as I have the NEtwork engineer online.

    However I have another question: Those regional offices that have correctly read the wnos.ini file are now “timing out when connecting to the “Published App” which is our vurtual Citrix Desktop. the only error in the WTOS Log is:
    HTTP open (ica.”ourcompanname”.local) = -1, errno 51

    However, these WTOS cannot connect as they just “time out” I now have all workstions logged in but NO WTOS?? Mental!

    Brian
    aka Fanflame

    #17223
    Fanflame
    Member
    • Total Post: 22
    • Regular Joe
    • ★★

    I have started a new Thread as I need to get an answer to the new error that we are now gettign.

    I am now getting the WTOS to read the wnos.ini file.

    Thanks to CG.

    Brian
    aka Fanflame

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.