Reset Expired Password V10L & XenDesktop 4

  • This topic is empty.
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #5860
    jlrobinson2171
    Member
    • Total Post: 6
    • Newbie

    I have deployed a bunch of V10L’s to access a shared virtual desktop. That portion works great. However I am having an issue with resetting passwords. The users that will be using these are all brand new AD accounts and all are required to change their password at first logon. I am testing this with a test account and I am getting no where fast.

    When I login, I get the following message:

    Your Windows password has expired. An ICA session is launched to change the same. You will be able to change the password in this session but you will not be permitted to complete the login process. Please click OK at the error and login with new password.

    If I click OK I get this message:

    Connecting to “http://icaserver.domain.com/Citirx/PNAgent/config.xml” …

    And then I get this:

    ICA[http://icaserver.domain.com/Citrix/PNAgent/config.xml]: Connection refused

    I tried adding PasswordServer=icaserver to the wnos.ini and that doesn’t work. I’ve made sure that changing passwords is enable in the Web Interface and I still can’t get past this.

    Any help will be appreciated. Thanks.

    #18230
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    PasswordServer=icaserver is the way to go. What value are you using “icaserver”?

    CG

    #18231
    jlrobinson2171
    Member
    • Total Post: 6
    • Newbie

    I tried the IP of the server and I also tried the NETBIOS name. Neither worked.

    #18232
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    OK, the problem is that th PasswordServer parameter is dependent on a XA server. It will not work with XD.
    If you do not have a XA server thn you would have to create a second RDP connection on the WTOS desktop just forpassword changes. Very, very ugly but that’s currently the only way.

    CG

    #18235
    jlrobinson2171
    Member
    • Total Post: 6
    • Newbie

    I do have an XA server. So do I put the address of the XA server?

    #18236
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Yes

    CG

    #18238
    jlrobinson2171
    Member
    • Total Post: 6
    • Newbie

    So I got this going and now when I login I get the message stating the password is expired and I click OK. I am then presented with a gray screen with nothing on it. I then get the following error:

    ICA[serverip]: Connection reset by peer

    If I click OK I get sent back to the login screen and the process repeats.

    Any ideas?

    #18248
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Can you try to disable/enable sound mapping?

    CG

    #18261
    jlrobinson2171
    Member
    • Total Post: 6
    • Newbie

    I set DisableSound to both yes and no and absolutely no change.

    #18262
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Hm, strange thing. But with this error message I am running out of thoughts.
    Sorry

    CG

    #18263
    jlrobinson2171
    Member
    • Total Post: 6
    • Newbie

    Really sucks not being able to have users change their passwords.

    #19087
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    This should be possible now with latest 6.4 or 6.5 firmware (6.5.10+).

    CG

    #19103
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    @jlrobinson2171 wrote:

    I have deployed a bunch of V10L’s to access a shared virtual desktop. That portion works great. However I am having an issue with resetting passwords. The users that will be using these are all brand new AD accounts and all are required to change their password at first logon. I am testing this with a test account and I am getting no where fast.

    When I login, I get the following message:

    Your Windows password has expired. An ICA session is launched to change the same. You will be able to change the password in this session but you will not be permitted to complete the login process. Please click OK at the error and login with new password.

    If I click OK I get this message:

    Connecting to “http://icaserver.domain.com/Citirx/PNAgent/config.xml” …

    And then I get this:

    ICA[http://icaserver.domain.com/Citrix/PNAgent/config.xml]: Connection refused

    I tried adding PasswordServer=icaserver to the wnos.ini and that doesn’t work. I’ve made sure that changing passwords is enable in the Web Interface and I still can’t get past this.

    Any help will be appreciated. Thanks.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.