Receipt Printer Passthrough Help!!!

Viewing 1 post (of 1 total)
  • Author
  • #53808
    • Total Post: 2
    • Newbie


    First off thanks for reading, really hope someone can help me get this thing going! Little details on the environment:

    Dell Wyse 3040 & 5470 Clients running ThinOS 8.6_511, BIOS up to date on both, and using the VMware Horizon 5.1 package. Our virtual environment is Horizon 7 and we’re using Windows 10 VMs.

    With our current configuration most printers, HP, Epson, etc passthrough fine and work as long as the driver is installed on the VM. We just started testing an EPSON TM-H6000IV receipt printer and it seems to passthrough (maybe halfway?). Without the driver it showed up in device manager at TM-H6000IV which is what it is so I thought, great! Installed the latest driver from Epson Support on the Windows 10 VM and while it shows under devices it shows as “unavailable”.

    On the Client side I hit print test page and it prints the numbers 0-9 a bunch which seemed fine but doesn’t populate the Printer Name and stuff like the others. In the event log is shows up as:

    USB: TM-H6000IV

    vUSB: device id(0x04b8,0x0202,0xff,0xff,0x02)

    and shows as EPSON TM_T88 connected on usb3 or port3 can’t recall atm.. not sure if it showing EPSON TM_T88 is good or bad since it’s not that model…

    Is it possible since the Wyse Client doesn’t seem to be identifying it correctly to just grab the HWID and force it to the VM? I’ve tried under WMS USB Redirection to enter the ID into the Force section and that didn’t work. Also tried adding an entry to the Global INI based off another article I found on here but still “unavailable”. Just wanted to see if anyone had any experience with these as we’d really like to move some reps at work to full virtual but they’d need these receipt printers to work. Any help or ideas will be greatly appreciated! Thanks for reading,

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.