Poor video performance in Direct RDP connection

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #107761
    MartinC
    Participant
    • Total Post: 1
    • Newbie

    Hi,

    This is my first post to the forum.

    Please could someone help sense-check me, because the usual amount of internet searching and forum trawling doesn’t seem to be getting me to where I need to be.

    I have purchased a Wyse 5070 with PCOIP running ThinOS with the intention of setting up a little test environment between the thin client and my Windows 10 Pro workstation.

    I am not using any servers, brokers, or intermediaries… I’m simply connecting from the thin client to my workstation using direct RDP.

    My workstation is using Intel integrated graphics, and has all driver and windows updates.

    I have tested in both ThinOS 8.6_710 and also 2205 (9.3.1129)

    In both cases I am unable to get a 1080p video clip, played in YouTube under Edge, to play in reasonable quality.

    I have applied the following GPO settings on the Windows 10 Pro workstation:
    Configure H.264/AVC hardware encoding for Remote Desktop Connections
    Prioritize H.264/AVC 444 graphics mode for Remote Desktop Connections
    Use hardware graphics adapters for all Remote Desktop Services sessions

    Am I missing something, or trying to do something that the system is not going to be able to do whatsoever?

    I’d be really grateful for any pointers!

    #107776
    lolix
    Participant
    • Total Post: 271
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    This is our environment : Wyse 5070 / ThinOS 8, connecting to W10 and W2019 RDSH servers in bare-bone RDP mode.

    They are virtual machines and we don’t even have hardware encoding, which is not a problem unless you’re using CAD software and/or using a server w/ many concurrent users (i.e. CPU bottleneck).

    It should work quite well. But don’t expect good quality in full screen mode on a , say,  27″ / 2560*1440 screen.

    Your first action is to check the network bandwidth between the Wyse and the workstation and if UDP is enabled (reported is the top blue bar of the Remote Desktop Windows in full screen).

    If you have a good bandwidth (100Mb/s topology or more) then you can play with the GPO RDP entries to minimize various “compressions” and “quality” entries.

    Our settings :

    • RDP Compression algorithm : Optimized to use less memory.
    • Configure H264/AVC… : Disabled.
    • Configure Image quality for RemoteFX : low
    • Configure RemoteFX Adaptative Graphics : Optimize for server scalability.
    • Priotirize H264… : Disabled.
    • Audio Quality : high.
Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.