multiple wnos.ini files

  • This topic is empty.
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1760
    Just
    Member
    • Total Post: 3
    • Newbie

    Hi,

    Is there a possibility to use more than one wnos.ini file for the same LAN subnet?
    The goal is to use two configurations for Wyse thin clients; from the documentation (and testing) it seems that only one configuration file can be accessed.

    Thanks, J.

    #15083
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    There are several ways to do this.
    1. Use WDM and its Default Device Configuration. Pros: Very flexible, simple. Cons: only WDM Enterprise
    2. Use ConfGen along with Guidos DDC lite (both on my website). Pros: no cost. Cons: manual overhead, as you have to add the MAC address of each unit
    3. Manually assign each unit the Fileserver/path and direct them this way to different wnos.ini files. Pros: no cost. Cons: Manual overhead
    4. If only a few unit need a different config you could use the “Include=$mac.ini” parameter and create mac.ini files in an “inc” folder beneath wnos. This way each unit will get the global wnos.ini and some named units will also get their special one. Using the “Exit=All” parameter at the end of the mac.ini and placing the Include parameter at astratgic place in the wnos.ini can help you that these special units will only get some setting (or none, if Include is the first parameter) of the wnos.ini. Exit=all will let the parser exit the mac.ini without jumping back to the wnos.ini to read the rest.

    CG

    #15084
    Just
    Member
    • Total Post: 3
    • Newbie

    In our case, option 4 was the best option (as relatively few units need the different configuration).
    After an hour testing with the mac.ini files we ‘ve got the different config working.

    Thanks for an amazingly fast (and helpful) reply, J.

    #15085
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    You are always welcome here.

    CG

    #17078
    vdiguy
    Member
    • Total Post: 5
    • Newbie

    I am trying to use multiple wnos.ini files with an existing Quest vWorkspace connection broker. I am using the DHCP scope options 161 and 188. I have my S10 and V10L units getting their configuration from C:Program Files (x86)Quest SoftwarevWorkspaceWYSEwnos and my wnos.ini file reads like this –

    FormUrl=logo.gif
    signon=1
    autoload=1
    autosignoff=yes
    privilege=High
    VNCPrompt=no
    DomainList=DALNET
    Device=audio volume=high
    SessionConfig=ALL UnmapPrinters=no Mapdisks=no
    ; TCX License for USB
    TCXLicense=4WVQT-1VCZD-J2FAP-ZAC1F-FOFT1
    ; TCX License for MMR
    TCXLicense=T4U5J-QCUUW-JAF2T-GSSDA-X57W8,UWY3X-9OOXB-JV8HK-F62MH-OVF03,K1BK9-1L9CO-W4W9C-SJOPT-5H7J3
    ; TCX License Key for Rich sound
    TCXLicense=TXV05-BU77H-S42NQ-7M3B6-FDR25

    Which of the 4 options listed do you think above do you think would be simplest and easiest to implement?

    #17084
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    I do not understand your problem. Please be more precise.

    CG

    #17085
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    BTW, are these production TCX licenses?

    #17096
    vdiguy
    Member
    • Total Post: 5
    • Newbie

    Well, i decided to go with #4, and I’ve almost got it working. I still need help with 2 things.

    1. When my units read the mac ini, in event log it says – “21: Invalid Statement: some code;**********…”

    2. Even though I specified no reconnect in the file, when I disconnect, it still tries to reconnect as long as plugged into network.

    I am trying to connect to RDS on Server 2008 R2 and here is my mac.ini file, and it was created with MacGen:

    SignOn=No
    SessionConfig=RDP DefaultColor=1
    CONNECT=RDP
    Host=rdp.sterneagee.com
    Description=”SAL RDS Farm”
    AutoConnect=yes
    Colors=16m
    Fullscreen=yes
    Resolution=default
    LocalCopy=no
    Exit=All

    Those are eval TCX keys and have been altered to protect their true identity.

    #17107
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    1. Can you give us the complete log message?
    2. Add reconnect=no to your RDP session config in the mac.ini.

    CG

    #17134
    vdiguy
    Member
    • Total Post: 5
    • Newbie

    I added reconnect=no and it still tries to reconnect. I am connecting to a Server 2008 R2 RDS Farm.

    Here is the complete log:

    1: System Version: HF 6.3.0_27.01f (ROM: 1.16i)
    2: CPU Version: VIA Eden Processor 800MHz
    3: Checking Ethernet Link …
    4: Checking Keyboard and Mouse …
    5: Built-in certificate BTCTRoot.crt is installed
    6: Built-in certificate Class3PCA_G2_v2.crt is installed
    7: Built-in certificate Class4PCA_G2_v2.crt is installed
    8: Built-in certificate GTECTGlobalRoot.crt is installed
    9: Built-in certificate GTECTRoot.crt is installed
    10: Built-in certificate Pc32ss_v4.crt is installed
    11: Built-in certificate SecureServer.crt is installed
    12: Built-in certificate EquafaxCA1.crt is installed
    13: Ethernet device version: VT6105 Rhine III.
    14: TCX USB: Local Device(0x0461,0x4d22,0x03,0x01,0x02)
    15: USB: Found a new device “HID” on port 1
    16: Looking up IP address from DHCP …
    17: Contacting SNTP [172.31.1.235] …
    18: Contacting Authentication Server …
    19: Connection broker connected
    20: Accessing system profile …
    21: Invalid statement: ;*************************************************************

    22: Contacting File Server …
    23: Contacting SNTP [172.31.1.235] …
    24: Accessing system profile …
    25: Invalid statement: ;*************************************************************

    26: Checking Software http:/wnos/VL10_wnos …
    27: Contacting SNTP [172.31.1.235] …

    #17151
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Check your ini file if there is a line like “;************************************************************* “.
    Remove the first three characters so it reads “;************************************************************* “

    CG

    #17183
    vdiguy
    Member
    • Total Post: 5
    • Newbie

    There is nothing like that in the mac.ini.
    It is a standard mac.ini created by MacGen and copied directly into the inc folder without making any changes.

    #17189
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    What about the wnos.ini?

    CG

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.