Issues with updating config files and sending remote commands to thin clients


Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #105832
    • Total Post: 1
    • Newbie

    Hello, I am still fairly new to WMS and Wyse devices, so please excuse me if I’m missing something obvious. We have an existing WMS server that we have been using to manage several hundred Wyse 3040 and 5010 thin clients at our institution, but the person who was managing it left and things stopped working correctly shortly afterwards. For months now, all of our thin clients have been unable to receive updated configuration files and they stopped responding to push commands for restarts and queries. Log files also fail to download, but I’m not sure if that worked previously. The devices are showing as compliant in the web console (we are using WMS version 1.3) and show that they are checking in hourly. We have tried reimaging devices, updated the certificate on the server, have checked the firewall to make sure nothing was getting blocked, and have looked through MongoDB and MariaDB logs and found nothing that looked relevant.

    If we try to switch a group of devices to another group, they do receive that command and we can manually reboot them to show the different configuration, but then they display a message saying that the reset key has been pressed (we did not press the G key to reset) and they will revert to their original configuration. The devices still show up in the new device group, but on the device page, you can see history of it switching back to the original group assignment. The changes we’ve made to the existing configurations on multiple device groups in the web console include different VMWare broker and Microsoft broker server addresses, but these changes never get applied to the devices, even after switching to completely different configurations. In the startup activity log, the devices say that they connect to the WMS server and have received full configurations from it, but nothing has updated. If we reimage the devices, they show factory defaults and then pull in the same configurations as before.

    I saw the web console used prior to these issues and everything seemed to function correctly; devices rebooted, changed their config files on command, and maintained those new configurations, rather than resetting. If we connect to the RDP server that the old/unchanged config file points to from the devices, we are still able to connect and the history of this connection shows up on the device pages in WMS.

    Any advice or suggestions on where we could look next to fix this strange behavior would be greatly appreciated. As they are currently, the devices are essentially stuck in time, but they seem to at least be communicating with the server.

    • Total Post: 36
    • Frequent Flyer
    • ★★★

    What does DELL support say about it?  The fact that you reimage a device and it still pulls down an out of date configuration suggests to me that you have a server-side issue.  It’s been a while since I poked around in the WMS database but I believe there is something akin to a message queue in there and maybe it has some old instructions stuck in there and is not clearing and accepting new commands.  If Change Group uses a separate queue for its operation, that could explain why you can do that but other instructions fail.  Would definitely recommend getting DELL to look at the WMS database or, if you have the time, getting familiar with it by picking a client and using its device ID to explore on your own.  The tables have pretty self-explanatory names so you may be able to identify the problem on your own.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.