Imprivata Fingerprinter Reader Issues

Viewing 1 post (of 1 total)
  • Author
  • #107544
    Jim Lathan
    • Total Post: 314
    • Jacked into The Matrix
    • ★★★★★★

    Hi All,

    We’re having an issue getting an TC710 fingerprint reader to work with 5010 and Optiplex 3000 thin clients.  We know ET710 is listed as an officially supported device, but the ET710 are listed as discontinued and the TC710 is the replacement.  Both have the same PID and VID info.  So not sure if it’s a setup issue, a bug or really a hardware compatibility issue.  So looking to see if possibly anyone has gotten this to work with the same or similar fingerprint reader.

    We have Imprivata setup in the WMS policy.  Proximity Card readers work fine with employee badges.

    At the login screen, if you plug in the fingerprint reader, you get a OneSign fingerprint prompt immediately followed by a popup “OneSign could not authenticate you.”
    If you click ok, and try to scan your fingerprint, it never works.

    Event Log on thin client shows device as “USB: UPEK Biometric Coprocessor vid: 0x147e pid:0x2016”

    If you log into windows with username and password and lock the session, the imprivata lock screen displays “Cannot communicate with the fingerprinte reader.”  If you then unplug the fingerprint reader and plug it back in sometimes windows detects it and will detect a fingerprint scan, but other times you get that same “Cannot Communicate…” error.

    Session Settings > Global Session Settings
    Enable HID Fingerprint Reader is enabled

    Session Settings > Citrix Session Settings
    USB Redirection is enabled
    Imprivata is enabled
    HID Fingerprint Reader is enabled

    Peripheral Management > USB Redirection
    Added 0x147e2016 to vUSB Force Local (also tried under Force Redirect)

    Thin Client:
    Optiplex 3000 (tried both OS 9.1.4097 and 9.1.6108)

    Packages Installed:

    Citrix Workspace App
    HID Fingerprinter Reader 210217.13
    Also tried adding Imprivata PIE but we don’t believe this is needed for this setup.


Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.