error certificate

  • This topic is empty.
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1786
    spyorche
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    Hi guys,

    What is this error?

    https: connect via SOCKS
    SSL: retcode=61 root certificate is not found locally
    https: SSL connect failed err= -1
    SSL: retcode=4 error occurred while reading/writing

    thanks for your help

    #15103
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Hi George,

    looks like you are trying to open a https site and did not have the cert imported before.
    This could be wireless config, WDM server, etc..
    Check your network settings.

    CG

    #15107
    spyorche
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    Hi,

    Now show:

    -Cannot open certificate file versignsecureserver.cer on file server!
    -Checking software ftp:/wnos/V10L_wnos

    😕

    #15108
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Rename to *.crt

    CG

    #15110
    spyorche
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    I rename the certificated and the problem persisted.

    😕

    I have Wyse V10L….V10L support certificates?

    Thanks for your help.

    George

    #15111
    spyorche
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    This is my wnos.ini

    #This will prevent the user being asked to log in to the local device.
    signon=0

    #Save settings if wnos.ini file off line
    EnableLocal=1

    #TCX License
    TCXLicense=VG8VF-WTLKJ-2JB31-Y0HM9-E6TM8

    #Citrix server.
    PnliteServer=https://office.perucopper.local

    #Certificado CSG
    AddCertificate=versignsecureserver.cer

    FileServer=10.67.1.31

    #This will upgrade to firmware if a newer version exists ing the ftp directory
    AutoLoad=1
    # Selects firmware update mode: 0=disable,1=upgrade/downgrade, 2=upgrade only

    #Set correct language
    language=au

    #Set screen resolution
    Resolution=1024×768 Refresh=75

    #Set desktop colour
    DeskColor=”255 255 255″

    #Set wallpaper, don’t forget to put a bitmap in the directory under
    #the wnos directory and call it bitmap (ie wnosbitmaplogo.bmp)
    Desktop=wyse.jpg

    #Start to lock down thin client, llockdown for kiosk mode
    Priviledge=high lockdown=yes

    #Remote Shadow options
    VncPrompt=0

    #Automatically turn off the terminal
    AutoSignoff=yes Shutdown=yes
    Shutdowncount=3

    #Disable the power button so kiosk can’t be turned off
    AutoPower=yes

    #Custom Screen Saver
    ScreenSaver=1o SoftSaver=yes Type=3 Image=screensave.jpg

    #Setup a connection to an ica server and autoconnect to a published
    # desktop called “My Desktop”.

    connect=ica
    description=”Login to Network…”
    icon=ica.bmp
    HttpBrowsing=1
    browserip=10.251.26.101
    Fullscreen=1
    autoconnect=1
    LocalCopy=No

    #15112
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Ypihave to rename this as well:

    AddCertificate=versignsecureserver.crt

    CG

    #15114
    spyorche
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    The certificate has the extension .cer. I tried renaming a .crt and nothing.

    And I think that the V10L model does not support certificates. This may be true?

    George

    #15115
    thinkthin
    Member
    • Total Post: 1686
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    What certificate are you importing? You V10L error message stated that the root certificate was missing so this is the one you need to import – not the one on the web server.

    The V10L ships with many of the common public certs but not all, here is how it is done:

    – Use the certificates snap in to export the root certificate from a windows box in the correct format. (do you know how to check this?)

    – Load this up in the V10L with the AddCertificate= command

    – Now when the V10L connects it will take the web site public certificate and compare it to the root certificate you loaded to validate the site,

    Cheers,
    -TT

    #15116
    spyorche
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    Clever!

    I already imported the certificate.

    Installed certificate versignsecureserver.cer on Flash!
    Installed certificate versignsecureserver.cer on RAM!
    Checking Software ftp:/wnos/VL10_wnos …

    That means the last line (Checking soft …)

    #15117
    thinkthin
    Member
    • Total Post: 1686
    • Jacked into The Matrix
    • ★★★★★★

    OK, if the certificate is imported do you still get:

    https: connect via SOCKS
    SSL: retcode=61 root certificate is not found locally

    in the event log – you posted this as your original issue. If this has gone what is the issue now, if its still there the root certificate is the wrong one to match the web server certificate,

    Cheers,
    -TT

    #15118
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    The unit is just checking the wnos folder for newer/older/other firmware then installed.

    CG

    #15123
    spyorche
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    Thanks CG
    8)

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.