C10LE / TCX /VMware / USB with Headset

  • This topic is empty.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #8372
    Nirvane
    Member
    • Total Post: 2
    • Newbie

    Hello, I’ve been banging my head against a wall for a few days with this. We have a client with C10LE thin clients using VMware View and they are trying to get a USB headset working.

    I’ve tried everything that I can find and I feel like I might be crossing some wires with several of the fixes overlapping.

    We are trying to use TCX for USB passthrough and everything I have tried has not allowed the headset to make its way through to the View client.

    Currently, USB redirection is not installed from the View agent and TCX is set to use TCX instead of VMwares redirect.

    The bios version is: 8.0_037

    TCX version is the latest as is the View version.

    Below is our wnos.ini and I appreciate any and all help!

    ;*************************************************************
    ;* *
    ;* This wnos.ini file was generated with the *
    ;* Configuration File Generator 7.1.02 *
    ;* Copyright by Thomas Moellerbernd *
    ;* *
    ;* https://technicalhelp.de *
    ;* *
    ;*************************************************************

    ;*************************************************************
    ;* General 1 *
    ;*************************************************************

    autoload=2
    Privilege=High

    ;*************************************************************
    ;* Peripherals *
    ;*************************************************************

    Language=Us

    ;*************************************************************
    ;* HDX/TCX *
    ;*************************************************************

    Device=vusb ForceRedirect=0x0c76,0x 160b,0x 01,0x 01,0x 00 Type=TCX

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=time.apple.com Timeformat=”12-hour format” Dateformat=mm/dd/yyyy
    TimeZone=’GMT – 06:00′ ManualOverride=yes

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    Device=Ethernet Speed=”Auto”
    VDIBroker=xxx.xxxxxx.com
    ConnectionBroker=VMware SecurityMode=None ConnectionType=RDP
    SignOn=Yes

    ;*************************************************************
    ;* General Session *
    ;*************************************************************

    SessionConfig=ALL VUSB_AUDIO=yes

    ;*************************************************************
    ;* RDP *
    ;*************************************************************

    SessionConfig=RDP EnableRecord=yes USBRedirection=TCX

    #25045
    Nirvane
    Member
    • Total Post: 2
    • Newbie

    Quick update, I feel like I am just missing something simple.

    I am connecting now via RDP to the virtual computer and it does not pull over any of the USB devices that appear in the event log. I was hoping it’d be a VMware issue.

    TCX only appears to show the local devices of the C10LE.

    I’ve tested with 2 different USB headphones and a USB hard drive, all show up as redirected in the log but never appear inside of Windows.

    What could I be missing?

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.