Bug Report: 8.6_511 (PCoIP) WiFi Gateway

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #53422
    lionelhuts
    Participant
    • Total Post: 8
    • Newbie

    On ThinOS 8.6_511, our WiFi connected 5070’s with PCoIP will, after a number of hours (give or take 5 hours), seemingly stop using their WLAN default gateway.  WiFi remains connected, but there is no communication with devices outside their own subnet.

    I can manually go into “Network Setup > General” and under “Network Interface as the Default Gateway” select “WLAN – Wireless Network Connection”.  This instantly restores communication to devices that need the gateway (non-Layer 2 traffic).  I have not found a WMS setting or INI parameter for this setting.

    To make matters worse, this selection does NOT survive a reboot on 8.6_511.  The system will go back to ENET as the network interface gateway.  Our users end up just rebooting the thin client every 5-10 hours to connect back to their RDP session.

    Downgrading to 8.6_027 seems to have resolved the issue.  (Our 5070’s on 8.6_111  also don’t seem to have a problem FWIW.)  Furthermore, the WLAN gateway setting on 8.6_027 survives a reboot.  Personally, I think this setting should be greyed out when ENET is disconnected.  (Who would want to use their disconnected ethernet NIC as their default gateway?)

    I will be reporting to Dell tomorrow. I just wanted to give a heads up to anyone experiencing similar issues.

    #53427
    ConfGen
    Keymaster
    • Total Post: 10692
    • Jedi Master
    • ★★★★★★★

    Please keep us updated on this one.
    Thanks

    CG

    #53431
    vinz
    Participant
    • Total Post: 44
    • Frequent Flyer
    • ★★★

    Hello,

    I’m facing the same issue  with my Wyse 5470 enterprise laptops with ThinOS 8.6_511.

    I want the WLAN to be the default gateway, but the system can’t remind this.

    Each time I return to the network setup, the ENET is the default gateway.

    I was relieved to find this post as I started to go crazy with this…

    I downgrade firmware to 8.6_303 but still the same issue… and unfortunately, that’s the factory fimware of my 5470 laptops (I tried a factory reset as well).

    I can’t find any older firmware for the 5470 laptop on the Dell Support website.

    A WMS setting or INI parameter would be great to bypass this a least.

     

     

    #53435
    lionelhuts
    Participant
    • Total Post: 8
    • Newbie

    Quick point of clarification:

    On 511, the WLAN setting not only doesn’t survive a reboot, it doesn’t even survive closing out of the network config screen.  After selecting the WLAN radio button and clicking OK, when you immediately re-open network setup, ENET will be selected again.

    Also, no WiFi problems on any of our terminals since downgrading the firmware yesterday.

    #53436
    lionelhuts
    Participant
    • Total Post: 8
    • Newbie

    @vinz

    I see a handful of older versions for your 5470 on Dell’s site.

    https://www.dell.com/support/home/en-us/product-support/product/wyse-5470-mobile-thin-client/drivers

    Select the raw image item, then it should expand and show an option for “older versions” to download.  8.6_108 is the oldest for that model I see available.

    #53437
    lionelhuts
    Participant
    • Total Post: 8
    • Newbie

    Update: I called Dell to report the issue.  They said engineering wouldn’t accept the report until I provided logs on 511 and then downgraded to 412 and tried that as well.

    I said sorry, but I’m not Dell’s personal QA. I understand their reasons for having their process that requires logs, but my report was basically a courtesy and an FYI, not to solve a problem impacting our production. My company won’t pay me to work in our lab testing firmware we don’t actually need to run the business.  Since we are fine on the old firmware, I have no incentive to do their testing.

    I would encourage anyone else having this problem to call in and report it. They indicated no other customers have said anything about this issue – not surprising since the firmware is relatively new. So maybe a large number of complaints would be enough motivation to get engineering to investigate, sans logs.

    #53439
    vinz
    Participant
    • Total Post: 44
    • Frequent Flyer
    • ★★★

    @lionelhuts : Thanks, I feel stupid to not have seen the “older versions” option !

    I will try older firmwares and keep you informed

    #53441
    vinz
    Participant
    • Total Post: 44
    • Frequent Flyer
    • ★★★

    After trying the firmware 8.6_206, same problem…

    Then I downgrade to 8.6_204, and now it works ! The WLAN Default Gateway is still there after closing the network setup screen, an event after a reboot.

    So 4 newer firmwares (8.6_206, 303, 412, 511) and this bug is still there ??

    (altough I didn’t try the 8.6_412, but I don’t think it works)

    I’m amazed that Dell doesn’t know this problem so far !

    #53442
    lionelhuts
    Participant
    • Total Post: 8
    • Newbie

    @vinz

    Please call them and report it if you haven’t already!

    #107506
    Twilley
    Participant
    • Total Post: 33
    • Frequent Flyer
    • ★★★

    Did anyone ever come up with a Fix for the ThinOS Default Gateway Bug?

    Our hospital has this issue on 8.6_807 and the devices just loose the default gateway every 4-5 hours.  Rebooting resolves it for another 4-5 hours.

    We cannot even set/modify the Default Gateway in Network Settings.  It’s like that value is read-only.

     

    Any workarounds would be helpful.

    #107508
    Twilley
    Participant
    • Total Post: 33
    • Frequent Flyer
    • ★★★

    We are trying the following as a work-around on our 8.6_807 devices until Dell gets it sorted out.  Applied via the SN.ini or Advanced WMS Console area.

    Device=NIC Default=WLAN

     

    #107615
    Twilley
    Participant
    • Total Post: 33
    • Frequent Flyer
    • ★★★

    UPDATE:

    The ORDER of certain wireless config lines in the INI can cause the ‘Network I/O’ errors.

    It was the ROOT cause of our Network I/O errors all along.  Our ‘Network I/O’ issues did not happen until ThinOS 8.6.

    It turns out that the older ConfGen tool generated the INI file with the ‘Device-wireless’ line at the END. (tested with 7.4)   Newer versions generate the same line AT THE BEGINNING of the wireless section.  (tested with 8.5)

     

    Example:

    From 2019

    IEEE8021X=yes network=wireless access=WPA2-ENT eap=yes eaptype=EAP-PEAP peapmschapdm=MyDomain.com peapeap=EAP-MSCHAPV2 \

    peapmschapun=UserID1 \

    peapmschappwdEnc=!!!!!!!!!!!!!!!!!!!!!!!!!!!

    Device=Wireless Mode=Infrastructure SSID=”OurSSID” RoamSensitive=-69dbm PreferBand=5G DisableWLAN=EnetUp Priority=”MySSID”

     

    vs

     

    2022

    Device=Wireless Mode=Infrastructure SSID=”OurSSID” RoamSensitive=-69dbm PreferBand=5G Priority=OurSSID DisableWLAN=EnetUp

    IEEE8021X=yes network=wireless Profile=OurSSID access=WPA2-ENT eap=yes eaptype=EAP-PEAP peapmschapdm=MyDomain.com peapeap=EAP-MSCHAPV2 \

    peapmschapun=UserID1 \

    peapmschappwdEnc=NNEH6MFCIHBCN6ACPGAAFFLIDFLL

     

    Changing the order alone will not resolve the issue.  We had to add “Device=NIC Default=WLAN” to the devices INI files to trigger some odd change within the device.  Once we did this, the devices no longer lost their default gateway after 4-5 hours of activity.  You can also just manually change the Default Gateway locally on the device once to “fix” the issue.

    Another interesting issue is that you cannot manually change the Default Gateway in any of the ThinOS  8.6.x builds.  Try it yourself.  Change the default gateway in the Network settings…go back and see if it sticks.  It will not.  It may just be a GUI bug, but something odd is going on here.

    Dell Support is aware of this, but ThinOS 8.6 is EOL and not being updated.  So this workaround will have to do for the thousands of Dell 5040s we have under warranty until 2024.  I thought I’d share my finding so that I could help someone else with this odd issue.

     

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.